Error installing Exchange Server 2013 – Error: The call to Microsoft Exchange Active Directory Topology service on server ‘TopologyClientTcpEndpoint (localhost)’ returned an error. Error details: An error occurred during forest discovery

Problem

When you install Exchange Server 2013, installation stuck at 97%

and than fail with the following error :

Error:

The following error was generated when “$error.Clear();

$maxWait = New-TimeSpan -Minutes 8

$timeout = Get-Date;

$timeout = $timeout.Add($maxWait);

$currTime = Get-Date;

$successfullySetConfigDC = $false;while($currTime -le $timeout)

{

$setSharedCDCErrors = @();

try

{

Set-SharedConfigDC -DomainController $RoleDomainController -ErrorVariable

setSharedCDCErrors -ErrorAction SilentlyContinue;

$successfullySetConfigDC = ($setSharedCDCErrors.Count -eq 0);

if($successfullySetConfigDC)

{

break;

}

Write-ExchangeSetupLog -Info (“An error ocurred while setting shared config DC.

Error: ” + $setSharedCDCErrors[0]);

}

catch

{

Write-ExchangeSetupLog -Info (“An exception ocurred while setting shared config

DC. Exception: ” + $_.Exception.Message);

}

Write-ExchangeSetupLog -Info (“Waiting 30 seconds before

attempting again.”);

Start-Sleep -Seconds 30;

$currTime = Get-Date;

}

if( -not $successfullySetConfigDC)

{

Write-ExchangeSetupLog -Error “Unable to set shared config DC.”;

}

” was run: “Unable to set shared config DC.”.

In addiction, in the installation log file ExchangeSetup.log under

c:\ExchangeSetupLogs you find something like this, repeated for 4/5 times :

[01/14/2013 13.35.50.0347] [2] Active Directory session settings

for ‘Set-SharedConfigDC’ are: View Entire Forest: ‘True’, Configuration Domain

Controller: ‘ITAMBS2013.resource.emea.local’, Preferred Global Catalog:

‘ITAMBS2013.resource.emea.local’, Preferred Domain Controllers: ‘{

ITAMBS2013.resource.emea.local }’

[01/14/2013 13.35.50.0347] [2]

Beginning processing Set-SharedConfigDC

-DomainController:’ITAMBS2013.resource.emea.local’

-ErrorVariable:’setSharedCDCErrors’ -ErrorAction:’SilentlyContinue’

[01/14/2013 13.35.56.0996] [2]

The call to Microsoft Exchange Active Directory Topology service on server

‘TopologyClientTcpEndpoint (localhost)’ returned an error. Error details An

error occurred during forest discovery (resource.emea.local)..

[01/14/2013 13.35.56.0996] [2]

An error occurred during forest discovery (resource.emea.local).

[01/14/2013 13.35.57.0043] [2]

The call to Microsoft Exchange Active Directory Topology service on server

‘TopologyClientTcpEndpoint (localhost)’ returned an error. Error details An

error occurred during forest discovery (resource.emea.local)..

[01/14/2013 13.35.57.0043] [2]

An error occurred during forest discovery (resource.emea.local).

[01/14/2013 13.35.57.0090] [2]

Ending processing Set-SharedConfigDC

[01/14/2013 13.35.57.0153] [2]

An error ocurred while setting shared config DC. Error: The call to Microsoft

Exchange Active Directory Topology service on server ‘TopologyClientTcpEndpoint

(localhost)’ returned an error. Error details An error occurred during forest

discovery (resource.emea.local)..

[01/14/2013 13.35.57.0168] [2]

Waiting 30 seconds before attempting again.

[01/14/2013 13.36.27.0188] [2]

Active Directory session settings for ‘Set-SharedConfigDC’ are: View Entire

Forest: ‘True’, Configuration Domain Controller:

‘ITAMBS2013.resource.emea.local’, Preferred Global Catalog:

‘ITAMBS2013.resource.emea.local’, Preferred Domain Controllers: ‘{

ITAMBS2013.resource.emea.local }’

[01/14/2013 13.36.27.0188] [2]

Beginning processing Set-SharedConfigDC

-DomainController:’ITAMBS2013.resource.emea.local’

-ErrorVariable:’setSharedCDCErrors’ -ErrorAction:’SilentlyContinue’

[01/14/2013 13.36.30.0538] [2]

The call to Microsoft Exchange Active Directory Topology service on server

‘TopologyClientTcpEndpoint (localhost)’ returned an error. Error details An

error occurred during forest discovery (resource.emea.local)..

[01/14/2013 13.36.30.0538] [2]

An error occurred during forest discovery (resource.emea.local).

[01/14/2013 13.36.30.0538] [2]

The call to Microsoft Exchange Active Directory Topology service on server

‘TopologyClientTcpEndpoint (localhost)’ returned an error. Error details An

error occurred during forest discovery (resource.emea.local)..

[01/14/2013 13.36.30.0538] [2]

An error occurred during forest discovery (resource.emea.local).

[01/14/2013 13.36.30.0538] [2]

Ending processing Set-SharedConfigDC

Resolution

This problem can be solved simply enablin IPV6 on network card.

To do so drop to the desktop in Server 2012. In the bottom right hand corner right

click the little monitor and select Open Network and Sharing

Center, then select Change Adapter Settings.Then select

your network card by right clicking it and selecting properties.

Make sure as you can see below that IPV6 is selected and enabled, once done

Exchange 2013 will install correctley (worked  for me on the fly,

but it’s better to give a reboot to the server).

enable-IPv6

NB. Also check that you have correctly configurated the Active Directory sites subnets.

 

 

Tagged , , , . Bookmark the permalink.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>